On Jun 14, 2011, at 2:44 AM, Eric Wong wrote:
> SASADA Koichi <ko1 / atdot.net> wrote:
>> The meaning of "with_gvl" in rb_thread_call_with_gvl() is "acquire GVL
>> and call passed function".  However, above two functions use then name
>> "*_with_gvl" in different meaning (run in GVL acquired situation, only).
> 
> I agree, "*_with_gvl" having two meanings is confusing.
> 
>> Do you have good naming idea for them?
> 
> Not sure, maybe "*_in_gvl"?

"*_if_gvl"?

> Or "ingvl_*" as prefix since io.c already uses "maygvl_" and "nogvl_" as
> prefixes.
> 
> Maybe we should avoid "gvl" in the name completely for these two
> functions.  Most Ruby functions need GVL anyways and they don't have
> "gvl" in the name.