Hi,

2011/6/10 Yukihiro Matsumoto <matz / ruby-lang.org>:
> |> If $SAFE is removed or widely changed, it will break backward
> |> compatibility, so it may be better to be done in 2.0.
> |
> |Do we have any idea if $SAFE is actually used?
>
> $SAFE level 1: yes, a lot. SAFE level 4: no, as far as I know.
> Those two levels are different beasts.

$SAFE level 4 is used in tDiary, which is a popular blog tool in Japan.

-- 
Shugo Maeda