On Fri, Jun 10, 2011 at 4:21 AM, Shugo Maeda <shugo / ruby-lang.org> wrote:

> If $SAFE is removed or widely changed, it will break backward
> compatibility, so it may be better to be done in 2.0.
>

Do we have any idea if $SAFE is actually used?

I worry that people who find themselves needing that much security are
forced to skip over $SAFE and use more robust options.  I admit that I'm
totally guessing about that though.

If true, it's a shame to spend so much development on this feature.

James Edward Gray II