On 05/06/2011, at 4:01 PM, Lazaridis Ilias wrote:
> The clarity of the method name should be rated in it's OO context,  
> like this:

I dispute the need for a method. That just forces someone to the  
documentation
to know what the code means.

The problem with the existing solution "if (__FILE__ == $0)" is that  
the meaning is
hidden. If the variables were named differently, this would be exactly  
the expression
that would best communicate the intent. To exaggerate, what we need is:

if __THIS_FILE__ == $THIS_PROGRAM
  ...
end

That is, the problem is that it's not obvious to a newcomer that  
__FILE__ means
the current source-code file, or that $0 means the name of the script  
being
executed. Especially the latter...

Clifford Heath.