Issue #4811 has been reported by Yuki Sonoda.

----------------------------------------
Bug #4811: Tk extconf.rb failed
http://redmine.ruby-lang.org/issues/4811

Author: Yuki Sonoda
Status: Open
Priority: Normal
Assignee: Hidetoshi Nagai
Category: ext
Target version: 1.9.3
ruby -v: ruby 1.9.3dev (2011-06-01 trunk 31887) [i386-darwin9.8.0]


=begin
On Mac OS X 10.5, with the folloing configure options, ext/tk/extconf.rb failed.
 '--prefix=/Users/yugui/local' '--program-suffix=-trunk' '--with-rubylibprefix=/Users/yugui/local/lib/ruby-trunk' '--with-soname=ruby-trunk' '--with-ridir=/Users/yugui/local/share/ri-trunk' '--docdir=/Users/yugui/local/share/doc/ruby-trunk' '--with-rubyhdrdir=/Users/yugui/local/include/ruby-1.9.1-trunk' '--with-gdbm-dir=/opt/local' '--with-libyaml-dir=/opt/local' '--with-libffi-dir=/opt/local' '--with-openssl-dir=/opt/local' '--disable-install-capi' 'CC=ccache gcc'

Here is the console message:
 configuring tk
 check functions.........
 check struct members..
 check libraries....
 Use ActiveTcl libraries (if available).
 Search tclConfig.sh and tkConfig.sh....................................
 Valid [tclConfig.sh, tkConfig.sh] are found in [["/System/Library/Frameworks/Tcl.framework", "/System/Library/Frameworks/Tk.framework"], ["/usr/lib", "/usr/lib"], ["/opt/local/lib", "/opt/local/lib"], ["/System/Library/Frameworks/Tcl.framework/Versions/Current", "/System/Library/Frameworks/Tk.framework/Versions/Current"], ["/System/Library/Frameworks/Tcl.framework/Versions/8.4", "/System/Library/Frameworks/Tk.framework/Versions/8.4"]]
 Use [tclConfig.sh, tkConfig.sh] == ["/System/Library/Frameworks/Tcl.framework/tclConfig.sh", "/System/Library/Frameworks/Tk.framework/tkConfig.sh"]
 Use MacOS X Frameworks.
 /Users/yugui/dev/ruby/mri/master/ext/tk/extconf.rb:1970:in `<top (required)>': can't convert nil into String (TypeError)
 from ../../ext/extmk.rb:164:in `load'
 from ../../ext/extmk.rb:164:in `extmake'
 from ../../ext/extmk.rb:454:in `block in <main>'
 from ../../ext/extmk.rb:450:in `each'
 from ../../ext/extmk.rb:450:in `<main>'
 make: *** [exts.mk] Error 1
 
This issue is also a release blocker of Ruby 1.9.2.
=end



-- 
http://redmine.ruby-lang.org