Em 29-05-2011 12:23, Rodrigo Rosenfeld Rosas escreveu:
> Em 28-05-2011 18:38, Xavier Shay escreveu:
>> Issue #3924 has been updated by Xavier Shay.
>>
>>
>> Rodrigo: Please try the latest version of rvm: rvm get head. 
>> Otherwise let me know what platform you are on.
>
> Hi Xavier, I'm always on latest RVM. I don't know yet why ruby-head is 
> resolving to 1.8.7-p334... But I don't intend to debug RVM for now. 
> I'll try to compile Ruby manually when I have some time...
>
> I'm on Debian unstable.

Never mind. It seems the problem is that I tried installing 1.8.7 once 
but couldn't due to this issue:

http://redmine.ruby-lang.org/issues/4556

Then, ruby-head was always resolving to it. Now that I've applied the 
patch provided on issue manually to ~/.rvm/src, I could install 1.8.7 
(needed for developing Gitorious). After installing it, ruby-head is 
resolving correctly. I'll try it and let you know.