Issue #4749 has been updated by Todd J.


apologies - meant to submit this to 1.9.2
----------------------------------------
Backport #4749: incorrect "TEENY" version number?
http://redmine.ruby-lang.org/issues/4749

Author: Todd J
Status: Open
Priority: Normal
Assignee: 
Category: 
Target version: 


=begin
New to ruby, but this seems off to me.  
Shouldn't line 5 in version.h be
(({#define RUBY_VERSION_TEENY 2})) ?

First 5 lines of ruby-1.9.2-p180/version.h:

(({#define RUBY_VERSION "1.9.2"}))

(({#define RUBY_PATCHLEVEL 180}))

(({#define RUBY_VERSION_MAJOR 1}))

(({#define RUBY_VERSION_MINOR 9}))

(({#define RUBY_VERSION_TEENY 1}))

So, running (({./configure})) results in this line in Makefile:
ruby_version = 1.9.1

And stuff gets installed in (({/usr/local/lib/ruby/1.9.1}))

This works: 
(({./configure --with-ruby-version=1.9.2}))

But shouldn't this be the default behavior?

As I said, I'm a nubie to ruby, so apologies if I'm missing something.
=end



-- 
http://redmine.ruby-lang.org