Hello,

In message "[ruby-core:36307] [Ruby 1.9 - Bug #4255][Open] When on a case-insensitive filesystem, "loaded features" search in require should ignore case"
    on May.18,2011 16:57:35, <nakahiro / gmail.com> wrote:
> Since the "fix" r30508 fixed the problem which did not exist, let's revert it.
> We can imagine contrived example, such as 'if rubygems inserts crafted String to $" by itself?'
> but we should "fix" it at that time, based on concrete examples of the problem.

I perfectly agree with you.

r30508 is not a bugfix.  It's a new spec/feature and introduced
without the deliberation.

At present, I have no certainty opinion about this spec change.
However, to change a spec, some clear purpose and reasons should
be presented.


> Given no objection, I'm going to revert it in a week. (Say NO now! 1.9.3 is coming :-)

Revert it now :)

If someone has objection, he/she should affix the reason and
the purpose and create a new ticket as feature request.


> Aside from this, we might need this case-insensitivity fix for 1.8.
> Is it too late?

There aren't any plan to release new 1.8...


Regards,
-- 
U.Nakamura <usa / garbagecollect.jp>