Hi,

Since ruby 1.9.2 appears to require ruby 1.8 in order to build
(--with-baseruby=), will ruby 1.8 be maintained indefinitely for this purpose?
It seems undoable to maintain binary packages for all possible platforms.

It's very unusual for a scripting language to depend on an earlier version of
itself to be available. Isn't this one of the reasons why miniruby is built?
Could the build be restructured to use miniruby instead?

Bug 3008 raised this issue but was Rejected. Perhaps touch'ing the generated
source files as suggested by Christian H?ltje could be used as a workaround?
People who build from source control could use this.

I don't expect an immediate fix, just wondering what the thinking is.

Thanks,
Jos

-- 
Jos Backus
jos at catnook.com