Hello,

2011/4/13  <redmine / ruby-lang.org>:
> I prefer this sort of method be an instance method of Range.

I can accept Range method, but why?
I think that the subject of this feature is the limited Numeric.


> You propse Range#bound, =A0but 'bound' as a verb is similar to jump/leap =
(and its intransitive), isn't it? Do you mean past particle form of 'bind' =
?

It resembles:

http://en.wikipedia.org/wiki/Upper_and_lower_bounds

But I did not think the name so deeply.
Another name is welcome.


> Anyway I propose Range#clamp as its name.
>
> Examples:
> * ((<Java 3D|URL:http://download.oracle.com/docs/cd/E17802_01/j2se/javase=
/technologies/desktop/java3d/forDevelopers/J3D_1_3_API/j3dapi/javax/vecmath=
/Tuple3d.html#clamp(double, double)>))
> * ((<DirectX|URL:http://msdn.microsoft.com/en-us/library/bb204824(VS.85).=
aspx>))

Thanks for the information.
The name would be good if it is really conventional.

--=20
Yusuke Endoh <mame / tsg.ne.jp>