On Sat, Apr 9, 2011 at 2:13 PM, Yukihiro Matsumoto <matz / ruby-lang.org> wrote:
>
> I am not sure whether adding new zip_with or adding zip with symbol at
> last would be better. Any opinion?
>
>                            matz.

An issue I have with zip taking a symbol is that ary1.zip(ary2, :+)
doesn't actually return a zipped array (of arrays). In that respect,
the result and the name "zip" don't align, with the additional
argument.

Is there such a need for this in core that we need a shortcut around
ary1.zip(ary2).map { |a, b| a + b }?