Issue #4239 has been updated by Zeno Davatz.


Dear Matsumoto-san

Well just FYI but the pg gem also does not work with Ruby 1.9.2 - it used to work with Ruby 1.8.6 and Ruby 1.9.1 - We just tested it with our Ruby 1.9.1 application.

So we truly have a history of inconsistency that will make a lot of Postgresql-Users not want to switch to Ruby 1.9.2 because some many things are different (dbi, pg, Regex). As far as I can tell the pg problem is more complex then the dbi problem. So who has knowledge about the pg Problem with Ruby 1.9.2?

And if you have a bit of a complex system you surely used Oniguruma in Ruby 1.8.6.

So there we go. I do not know but is this a q.e.d for inconsistency? This is not healthy for your grandmother.

Now who has to adapt? pg gem to Ruby or Ruby to pg?

Again I would say that Ruby 1.8.8 should somehow bridge this gap as I guess Ruby 1.9.2 does not want to adapt.

Best
Zeno
----------------------------------------
http://redmine.ruby-lang.org/issues/show/4239

----------------------------------------
http://redmine.ruby-lang.org