On Wed, Jan 19, 2011 at 5:54 AM, Rodrigo Rosenfeld Rosas
<rr.rosas / gmail.com> wrote:
> I like the cast_to/cast_from names and I guess it avoids conflict with most
> libraries.

They're not bad, but casting to me means something altogether
different: treating a an object as a different type, while still
referencing the same object.

I don't know what "cast" means generally in language design/type
theory, but it seems wrong for what's happening here. In our case,
we're asking the object to convert itself to a specific type...not
casting it to a type it already implements.

Perhaps convert_to and convert_from would be more in line with what's happening?

- Charlie