On Jan 13, 2011, at 07:24 , Tanaka Akira wrote:

> Apart from that, I'm afraid startup cost.

Not being able to upgrade is a far bigger problem than startup cost.

We can address any remaining startup costs in rubygems directly. But if users can't upgrade, none of this matters. The current rubygems in trunk is broken. The biggest part of that is gem_prelude. I'm addressing breakage before I address fear.