Issue #3150 has been updated by Martin Bosslet.


Using Ubuntu 10.04 and OpenSSL 1.0.0c, I get the expected exception.
----------------------------------------
http://redmine.ruby-lang.org/issues/show/3150

----------------------------------------
http://redmine.ruby-lang.org