Bug #4185: ruby 1.9.2 p0 installation issue
http://redmine.ruby-lang.org/issues/show/4185

Author: ravish nayak
Status: Open, Priority: Urgent
ruby -v: 1.9.2 p0

Hi,

I am trying to install ruby 1.9.2 p0 and 1.9.2 rc2 version on redhat linux4 under x86 architecture while compiling the source code I am 
getting following errors and compilation was not successfull

First one is

installing binary commands:   TOOLROOT/ruby/ruby/1.9.2/rhe4-x86_64/bin
installing base libraries:    TOOLROOT/ruby/ruby/1.9.2/rhe4-x86_64/lib
installing arch files:        TOOLROOT/ruby/ruby/1.9.2/rhe4-x86_64/lib/ruby/1.9.1/x86_64-linux
installing extension objects: TOOLROOT/ruby/ruby/1.9.2/rhe4-x86_64/lib/ruby/1.9.1/x86_64-linux
installing extension objects: TOOLROOT/ruby/ruby/1.9.2/rhe4-x86_64/lib/ruby/site_ruby/1.9.1/x86_64-linux
installing extension objects: TOOLROOT/ruby/ruby/1.9.2/rhe4-x86_64/lib/ruby/vendor_ruby/1.9.1/x86_64-linux
installing extension headers: TOOLROOT/ruby/ruby/1.9.2/rhe4-x86_64/include/ruby-1.9.1/x86_64-linux
installing extension scripts: TOOLROOT/ruby/ruby/1.9.2/rhe4-x86_64/lib/ruby/1.9.1
installing extension scripts: TOOLROOT/ruby/ruby/1.9.2/rhe4-x86_64/lib/ruby/site_ruby/1.9.1
installing extension scripts: TOOLROOT/ruby/ruby/1.9.2/rhe4-x86_64/lib/ruby/vendor_ruby/1.9.1
installing extension headers: TOOLROOT/ruby/ruby/1.9.2/rhe4-x86_64/include/ruby-1.9.1/ruby
installing rdoc:              TOOLROOT/ruby/ruby/1.9.2/rhe4-x86_64/share/ri/1.9.1/system
installing capi-docs:         TOOLROOT/ruby/ruby/1.9.2/rhe4-x86_64/share/doc/ruby
installing command scripts:   TOOLROOT/ruby/ruby/1.9.2/rhe4-x86_64/bin
installing library scripts:   TOOLROOT/ruby/ruby/1.9.2/rhe4-x86_64/lib/ruby/1.9.1
installing common headers:    TOOLROOT/ruby/ruby/1.9.2/rhe4-x86_64/include/ruby-1.9.1
installing manpages:          TOOLROOT/ruby/ruby/1.9.2/common/man/man1
installing default gems:      TOOLROOT/ruby/ruby/1.9.2/rhe4-x86_64/lib/ruby/gems/1.9.1 (cache, 
doc, gems, specifications)
                              rake 0.8.7
                              rdoc 2.5.8
                              minitest 1.6.0
tmk: Setting permissions on '/scratch/ravnay01/tmp_ruby_ruby_1.9.2/TOOLROOT/ruby/ruby/1.9.2/
rhe4-x86_64'
chmod 775 .
find rhe4-x86_64 -type d -print | xargs chmod a+x
chmod: cannot access `rhe4-x86_64/share/ri/1.9.1/system/Set/dig': No such file or directory
chmod: cannot access `=': No such file or directory
chmod: cannot access `{}': No such file or directory
chmod: cannot access `rhe4-x86_64/share/ri/1.9.1/system/IRB/(MagicFile': No such file or director
y
chmod: cannot access `=': No such file or directory
chmod: cannot access `Object.new)': No such file or directory
tmk: child process exited abnormally
tmk: tmk: exiting.
tmk: exiting.


second one 

 
If try to run executable file which is there in bin directory I am getting following error..


./ruby: error while loading shared libraries: libruby.so.1.9: cannot open shared object file: No such file or directory


----------------------------------------
http://redmine.ruby-lang.org