Bug #3937: LC_ALL=zh_CN cause WIN32OLERuntimeError when require 'win32ole'
http://redmine.ruby-lang.org/issues/show/3937

Author: oCameLo Hsu
Status: Open, Priority: Normal
Category: ext, Target version: 1.9.2
ruby -v: ruby 1.9.2p0 (2010-08-18) [i386-mingw32]

zh_CN.gbk and zh_CN.utf8 work fine, but zh_CN not.


C:\>ruby -v
ruby 1.9.2p0 (2010-08-18) [i386-mingw32]

C:\>set LC_ALL=zh_CN.gbk

C:\>ruby -e "require 'win32ole';puts 'ok'"
ok

C:\>set LC_ALL=zh_CN

C:\>ruby -e "require 'win32ole';puts 'ok'"
<internal:lib/rubygems/custom_require>:29:in `require': codepage should be WIN32OLE::CP_ACP, WIN32OLE::CP_OEMCP, WIN32OLE::CP_MACCP, WIN32OLE::CP_THREAD_ACP, WIN32OLE::CP_SYMBOL, WIN32OLE::CP_UTF7, WIN32OLE::CP_UTF8, or installed codepage.(WIN32OLERuntimeError)
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from D:/Opt/Ruby/Current/lib/ruby/1.9.1/win32ole.rb:1:in `<top (required)>'
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from -e:1:in `<main>'


----------------------------------------
http://redmine.ruby-lang.org