Issue #3666 has been updated by Luis Lavena.


Hello Hiroki,

After reading that post, it is clear something has not been correctly communicated to the developers:

1) Ruby 1.9.2-p0 has been compiled with GCC 4.5.0 and needs GCC 4.5.0, from their instructions it is clear they are using the old DevKit (this affects ruby.h, rbconfig.rb and win32.h listed as patches

2) It is clear the dependency on MSVC tools (lib.exe) by extconf even when lib is not available by GCC.

I believe a better patch needs to be provided to these developers that solves their specific build problems.
----------------------------------------
http://redmine.ruby-lang.org/issues/show/3666

----------------------------------------
http://redmine.ruby-lang.org