Hi,

2010/10/3 KOSAKI Motohiro <kosaki.motohiro / gmail.com>:
> 2010/10/1 Axel Reinhold <ruby / freakout.de>:
>> Subject: ruby-1.9.2-p0 no more support for glibc-2.1.x - broken pthread
>>
>> Up to ruby-1.9.1-p430 i could compile/link/production on old
>> glibc-2.1.x systems without problems (RedHat 6.2).
>>
>> ruby-1.9.2-p0 still compiles/link and works but no more 100%
>> -> when i need threads i get:
>>
>>   "ruby engine can initialize only in the main thread"
>>
>> this is due changes in thread_pthread.c which has abandoned support
>> for systems without pthread_getattr_np setting STACKADDR_AVAILABLE
>> to 0 and raising the above message.
>>
>> For me this is a severe regression - can this be fixed please?
>> I have some systems i cannot upgrade due to non-open source issues
>> and i need to have up-to-date ruby/rails on these.
>>
>> Thanks for any help.
>
> This is a regression since rr27789.
>
> mame-san, can you please review an attached patch?


I could be wrong, but I doubt if the patch works.
I guess th->machine_stack_start will NOT be null even if STACKADDR_AVAILABLE is
0 since th->machine_stack_start looks like initialized in thread_start_func_2.

Did you confirm that the patch works?  I have no objection if it works.

-- 
Yusuke Endoh <mame / tsg.ne.jp>