Feature #3888: configure.in compatibility with autoconf 2.68
http://redmine.ruby-lang.org/issues/show/3888

Author: Luis Lavena
Status: Open, Priority: Normal
Category: build

MacPorts just updated to autoconf to version 2.68:

autoconf (GNU Autoconf) 2.68

And now Ruby trunk at r 29366 is alerting some AC warnings:

<pre><code>
configure.in:1477: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:194: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2591: _AC_COMPILE_IFELSE is expanded from...
../../lib/autoconf/general.m4:2607: AC_COMPILE_IFELSE is expanded from...
../../lib/m4sugar/m4sh.m4:606: AS_IF is expanded from...
../../lib/autoconf/general.m4:2032: AC_CACHE_VAL is expanded from...
../../lib/autoconf/general.m4:2053: AC_CACHE_CHECK is expanded from...
configure.in:1477: the top level
</code></pre>

installed ports that could be affecting this:

$ port installed autoconf m4 automake 
The following ports are currently installed:
  autoconf @2.68_0 (active)
  automake @1.11.1_0 (active)
  m4 @1.4.15_0 (active)

Thank you


----------------------------------------
http://redmine.ruby-lang.org