from the first post:

[[[
/usr/local/bin/ruby(rb_vm_bugreport+0x9e) [0x522bee]
/usr/local/bin/ruby() [0x563f98]
/usr/local/bin/ruby(rb_bug+0xb1) [0x564131]
/usr/local/bin/ruby(rb_check_type+0xae) [0x5657ae]
/usr/lib/ruby/gems/1.8/gems/sqlite3-ruby-1.3.1/lib/sqlite3/sqlite3_native.so(+0x4162) [0x7f99e157f162]
                   ^^^
]]]

so he is trying to use the 1.8 extension with 1.9.

    darix

-- 
           openSUSE - SUSE Linux is my linux
               openSUSE is good for you
                   www.opensuse.org