Issue #3773 has been updated by Thomas Sawyer.


Mainly I suggest it be added to core on the basis that 1) since we already have Module#name we might as well have this too, and 2) it is very inefficient and non-robust to code in pure Ruby.

And yes, I agree that #parent is the wrong name. What would you call it? I want to know b/c, even if you do not add it to core, I want to add it to Ruby Facets, but I am not sure what to call it myself.
----------------------------------------
http://redmine.ruby-lang.org/issues/show/3773

----------------------------------------
http://redmine.ruby-lang.org