Issue #3818 has been updated by Eric Hodel.


Apply it, reinstall ruby, reinstall the extension.

The extension may need to use have_function in extconf.rb to determine if it's being compiled for ruby 1.8 or ruby 1.9.
----------------------------------------
http://redmine.ruby-lang.org/issues/show/3818

----------------------------------------
http://redmine.ruby-lang.org