Hi,

2010/9/9 Aaron Patterson <aaron / tenderlovemaking.com>:
> Can you elaborate on the criteria required for importing a library to
> stdlib?  I do not understand the requirements.

IMO, we need either:

  - An unavoidable reason why the core team couldn't help but bundle
    it, or
  - Matz or Yugui's authority ;-)


Ruby 1.8 was an epoch of enhancing stdlib, but unfortunately, many
maintainers left, which results in severe maintenance problems.
In addition, Ruby 1.9 includes RubyGems, which allow users to
install a library easily.
Furthermore, Ruby has been criticized because of disregard for
compatibility.

These three made the 1.9 stdlib set very pedantic, I think.

-- 
Yusuke Endoh <mame / tsg.ne.jp>