2010/9/3 Ryan Davis <ryand-ruby / zenspider.com>:
>
> On Sep 2, 2010, at 22:34 , NARUSE, Yui wrote:
>
>> I answered nokogiri's dependency with libxml is a problem on some environments.
>> And if Ruby bundles nokogiri, its update is restricted by Ruby's schedule.
>
> Isn't that also true of ffi's dependency on libffi?

Yes, it is open problem on Windows.
Why fiddle is accepted is dl2 can't work well on x86_64 and it can't be fixed.

The problem is described following in Japanese but most quotation is in English.
http://mkosaki.blog46.fc2.com/blog-entry-1069.html

So we needed another impl.


Well, we could obsolete dl and recommend ffi gem.
It is discussed just before 1.9.2 release but it's too late.

-- 
NARUSE, Yui
naruse / airemix.jp