Bug #3709: Ruby 1.9.1 with openssl 1.0
http://redmine.ruby-lang.org/issues/show/3709

Author: Edmund Highcock
Status: Open, Priority: Normal
Category: ext, Target version: 1.9.1
ruby -v: ruby 1.9.1p430 (2010-08-16 revision 28998) [x86_64-linux]

Hi,

The stable version of Ruby 1.9.1 that I have downloaded from http://www.ruby-lang.org/en/downloads/ does not have the latest openssl 1.0 patch applied and so will not compile with openssl 1.0.

The latest stable snapshot on the same page also won't compile with openssl 1.0.

openssl 1.0 is becoming a standard part of distributions (e.g. openSUSE 11.3) and so these two will start failing for more and more people.

Could the patch be applied to these two releases? I distribute a program which requires Ruby 1.9, and I would prefer it if my users didn't have to download the development version (or start applying patches themselves :-o )!

Also, I have tried applying the patch in Bug #3093  (http://redmine.ruby-lang.org/issues/show/3093) to the stable version, and it failed to fix the problem.

Thanks in advance,

Edmund


----------------------------------------
http://redmine.ruby-lang.org