Backport #3694: Error during make for 1.9.2-rc2
http://redmine.ruby-lang.org/issues/show/3694

Author: Iain Barnett
Status: Open, Priority: Normal

Trying to install, get the following message during make:

./tool/compile_prelude.rb:188: [BUG] Segmentation fault
ruby 1.9.2dev (2010-07-11 revision 28618) [x86_64-darwin10.4.0]

-- control frame ----------
c:0003 p:0051 s:0012 b:0010 l:000009 d:000009 METHOD ./tool/compile_prelude.rb:188
c:0002 p:---- s:0004 b:0004 l:000003 d:000003 FINISH
c:0001 p:0000 s:0002 b:0002 l:0015a8 d:0015a8 TOP   
---------------------------
-- Ruby level backtrace information ----------------------------------------
./tool/compile_prelude.rb:188:in `emit'

-- C level backtrace information -------------------------------------------

[NOTE]
You may have encountered a bug in the Ruby interpreter or extension libraries.
Bug reports are welcome.
For details: http://www.ruby-lang.org/bugreport.html

make: *** [prelude.c] Abort trap


This was the command to configure:

./configure --prefix=/Library/Frameworks/Ruby.framework/Versions/1.9.2-rc2  --enable-shared

I also changed vm_opts.h to:

#define OPT_TAILCALL_OPTIMIZATION    1


My system information:
ProductName:	Mac OS X
ProductVersion:	10.6.4
BuildVersion:	10F569

I've installed 1.9.1-p378 and p429 successfully in the last few days. I've attached the full output to the terminal. Let me know if there's any more information I can give.

Btw, I tried to subscribe to the Ruby Core mailing list to ask about this but that didn't work automatically or manually.

Regards,
Iain


----------------------------------------
http://redmine.ruby-lang.org