2010/8/2 Shyouhei Urabe <redmine / ruby-lang.org>:
>
>> Don't use URI.encode.
>
> Then should it issue a warning at least?

% ruby -ruri -ve 'URI.encode("a")'
ruby 1.9.3dev (2010-06-10 trunk 28257) [i686-linux]
-e:1:in `<main>': warning: URI.escape is obsolete
-- 
Tanaka Akira