On Jul 21, 2010, at 3:55 AM, Nobuyoshi Nakada wrote:

> Hi,
>=20
> At Wed, 21 Jul 2010 16:35:49 +0900,
> Nick Markwell wrote in [ruby-core:31391]:
>> I agree, Numeric#multiple? seems more appropriate.
>=20
> Or Numeric#divisible?, I'm not sure which is better.  Maybe
> define both?
>=20
> And, it's arguable about inexact numbers, I guess.
>=20
> --=20
> Nobu Nakada
>=20


"divisible" and "divisor" should not mean the same thing, and I vote for =
Numeric#divisible? (or more verbosely, Numeric#divisible_by?) for the =
present concept under discussion.

When I see "10.divisor? 5", it reads to me "Is 10 a divisor of 5?", just =
like "h.kind_of? Hash" reads "Is h a kind of Hash?".

On the other hand, "10.divisible? 5" reads "Is 10 divisible by 5?".=