On Jul 16, 2010, at 9:07 AM, Roger Pack wrote:

>> Wonderful! Thank you Yusuke! I'll keep a close eye on things to watch for anyone reporting bugs.
> 
> Evan, could you also merge in Nobu's patch to load full rubygems when
> users do an
> 
> gem 'xxx'
> 
> otherwise gem_prelude is still quite unsafe (as pointed out by James,
> I only understood it just now).
> 
> Also could that change (after committed) be backported to 1.9.2 branch, please?
> I just want to clear up confusion for end users, and it causes some
> obscure and hard to understand bugs.
> That would be awesome!

No, I can't backport anything to 1.9.2. It's unlikely this will happen for 1.9.2 honestly. I know that my patch for 1.9.2 is less than ideal, but it at least works around the problem in some ways.

If Yusuke indicates it would be fine to revise it, we can do that. But I think that they don't want to change 1.9.2 any more.

> -r
> 
>