Yes. Almost everything gem-related might break when the wrong versions are
being loaded and Bundler is an application dependency manager, so it deals
with gems/versions.

If this bug isn't fixed, Rails 3 won't work on 1.9.2. If this happens, there
will be no official support for it and people will just keep using the good
old 1.8.7. I agree with Evan: It's crucial for ruby-core developers to
consider this before letting this bug unfixed on 1.9.2. Please address this
issue.

---
http://goncalossilva.com

im: goncalossilva / gmail.com
twitter: http://twitter.com/goncalossilva


On Mon, Jul 12, 2010 at 11:40, Nobuyoshi Nakada <nobu / ruby-lang.org> wrote:

> Hi,
>
> At Mon, 12 Jul 2010 16:41:06 +0900,
> Evan Phoenix wrote in [ruby-core:31206]:
> > This is very bad news. This fix effects a lot of people. I
> > did not respond because Roger indicate he could not reproduce
> > it himself. No one has been able to reproduce the issue,
> > including Roger himself. If that is the reason the fix did
> > not make it into 1.9.2, that's very sad.
>
> Sorry, I can't find if Roger tried it with 1.9.2, not with
> trunk.  In [ruby-core:31108], he found it with trunk on mingw
> but couldn't reproduce it on linux.
>
> > This is exactly backwards from what I understand. This bug
> > means that bundler can not run on 1.9.2, and thus rails 3.0
> > can not run on 1.9.2. This is what Yehuda has told me.
>
> Bundler also depends on this behavior?
>
> --
> Nobu Nakada
>
>