> What version of RubyGems?

C:\installs\ruby_trunk_no_patches_installed\bin>gem -v
1.3.7

C:\installs\ruby_trunk_no_patches_installed\bin>ruby -v
ruby 1.9.3dev (2010-07-08 trunk 28571) [i386-mingw32]

C:\installs\ruby_trunk_no_patches_installed\bin>gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.7
  - RUBY VERSION: 1.9.3 (2010-07-08 patchlevel -1) [i386-mingw32]
  - INSTALLATION DIRECTORY:
C:/installs/ruby_trunk_no_patches_installed/lib/ruby/gems/1.9.1
  - RUBY EXECUTABLE: C:/installs/ruby_trunk_no_patches_installed/bin/ruby.exe
  - EXECUTABLE DIRECTORY: C:/installs/ruby_trunk_no_patches_installed/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86-mingw32
  - GEM PATHS:
     - C:/installs/ruby_trunk_no_patches_installed/lib/ruby/gems/1.9.1
     - C:/Users/packrd/.gem/ruby/1.9.1
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
     - "gem" => "--no-ri --no-rdoc"
  - REMOTE SOURCES:
     - http://rubygems.org/

> Is this based on RubyInstaller?

Local build, so not directly.

> "gem" will load directly RubyGems, which is not the intend of prelude.

yeah with "new" gem_prelude even doing
require 'rubygems'
loads full rubygems.

How to reproduce:
install the rdoc-data gem, then do

>> require 'rubygems'

With trunk.