Issue #3140 has been updated by Roger Pack.


Unfortunately this patch basically invalidates the usefulness of gem_prelude for ruby's gem generated binary scripts, since they all include a

gem 'xxx'

in them.  But I suppose it's worth it to improve compatibility for people who have newer versions of a gem installed than the ones they actually *use* 
----------------------------------------
http://redmine.ruby-lang.org/issues/show/3140

----------------------------------------
http://redmine.ruby-lang.org