Issue #2032 has been updated by Yusuke Endoh.

Status changed from Closed to Assigned
Priority changed from High to Urgent

Hi,

> I merged a patch in [ruby-dev:39172]: reject readline6.

I really hate the check that rejects linking with readline6,
because it is actually *new feature*.  The 1.9.2 feature was
already frozen.  Rather, preview3 was even released.
I'm not against the feature itself, but now is a bad time.
I'll revert in a few days.

Of course, the license issue still remains.  But it is enough
to just add a note to document.  I think we have no obligation
to add such a mechanism to check readline6 and to reject its
link.


In addition, I suggest to change Ruby's license to triple
(Matz's, GPLv2 and GPLv3) right now.  I think no one objects
GPLv3.
The current license will makes us unhappy because we cannot use
not only readline6 but also other GPLv3 libraries that will be
increased.
We can discuss adding "or later" clause or changing to BSDL
after 1.9.2 is released.

Matz, how about the triple license?

-- 
Yusuke Endoh <mame / tsg.ne.jp>
----------------------------------------
http://redmine.ruby-lang.org/issues/show/2032

----------------------------------------
http://redmine.ruby-lang.org