Bug #3353: Building 32-bit only on Snow Leopard (dylib failed to build)
http://redmine.ruby-lang.org/issues/show/3353

Author: Bryan Ross
Status: Open, Priority: Low
Category: build
ruby -v: 1.9.1

Okay, I know this isn't all THAT helpful, but I was trying to build ruby 1.9.1 on Snow Leopard, but 32-bit only. I had CFLAGS, LDFLAGS, CXXFLAGS, and DLDFLAGS all set to '-arch i386'

Everything would be fine, all *.o files would be built i386, but when it came time to create libruby.1.9.1.dylib, the -arch i386 flag was not present. I'm no autoconf genius, so I have absolutely NO idea how to patch this. But all I did was re-run the failing command and manually added the -arch i386 command, and it worked.

A minor point, but kind of annoying nonetheless.

I have attached the relevant output of 'make'.


----------------------------------------
http://redmine.ruby-lang.org