Bug #3294: [PATCH] Allow build of dbm extension with Berkeley DB 5.0 series
http://redmine.ruby-lang.org/issues/show/3294

Author: Diego E. Pettenò
Status: Open, Priority: Normal
ruby -v: ruby 1.8.7 (2010-01-10 patchlevel 249) [x86_64-linux] 

In the new version of BerkDB, to use the DBM functions you need to define the HAVE_DBM macro, otherwise the functions won't be defined (before, simply using DB_DBM_HSEARCH was enough). The attached patch enables that to make sure that it is possible to build the dbm extension properly.


----------------------------------------
http://redmine.ruby-lang.org