Hello,

In message "[ruby-core:30044] Re: [Bug #3112] require "yaml" doesn't use psych as default"
    on May.06,2010 15:46:00, <aaron / tenderlovemaking.com> wrote:
> > Bug #3112: require "yaml" doesn't use psych as default
> > http://redmine.ruby-lang.org/issues/show/3112
> > 
> > Author: Usaku NAKAMURA
> > Status: Open, Priority: Normal
> > Category: lib, Target version: 1.9.2
> > ruby -v: ruby 1.9.2dev (2010-04-08 trunk 27255)
> > 
> > why?
> 
> Rails runs with Psych as default.  Our applications at work run well
> with Psych as default.
> 
> I would like to make Psych default YAML parser for 1.9.2.  What do you
> think?

IMO, if Psych is enough compatible with Syck, Psych should be
the default YAML parser, like the way of the decision performed
about ext/fiddle and ext/dl recently.

However, naruse has already explained the intention of yugui at
[ruby-core:29377].
I don't want to disobey the branch/release manager about this
matter :)


Regards,
-- 
U.Nakamura <usa / garbagecollect.jp>