Issue #3174 has been updated by Ingo Meierhoff.


if you would like to reproduce it with 1.9.1p378 you have to ensure that your postgres db is fast enough
(for this reason I used in postgres.conf: 
  fsync = off
  synchronous_commit = off
  wal_writer_delay = 2s  
)

until now I was not able to reproduce the error using version 1.9.2 so it seems to be fixed
or my system is not fast enough
$ ruby -v
ruby 1.9.2dev (2010-04-22 trunk 27435) [i686-linux]
----------------------------------------
http://redmine.ruby-lang.org/issues/show/3174

----------------------------------------
http://redmine.ruby-lang.org