Issue #2152 has been updated by Benoit Daloze.


Sorry for my noisy messages with html on redmine, all my apologies.

I just send here back the last message from ruby-core (which seems to not be on redmine):

On 15 April 2010 22:38, Roger Pack wrote:
>> The option previously proposed is
>>
>> Float#to_s : human
>> Float#inspect : verbose
>>
>> Another option:
>>
>> Float#to_s : verbose
>> Float#inspect : verbose
>> Float#to_hs : human (or to_ps or what not, for pretty string--not sure


> Why to have two methods (to_s and inspect) doing the same thing?
> They are not supposed to be aliased,
> this is the case in many objects (except the ones having a unique perfect
> representation).

Good point.
Because of this +1 for first option mentioned, from me.
It would seem in this instance that we do actually prefer two methods,
and two already exist for us to use.

Thanks!
-rp

---

Can we still decide for this or is it too late ?
----------------------------------------
http://redmine.ruby-lang.org/issues/show/2152

----------------------------------------
http://redmine.ruby-lang.org