>
> The option previously proposed is
>
> Float#to_s : human
> Float#inspect : verbose
>
> Another option:
>
> Float#to_s : verbose
> Float#inspect : verbose
> Float#to_hs : human (or to_ps or what not, for pretty string--not sure
> if there is a convention for that name or not)
>
> Any feedbacks or preferences there?  I'd probably be ok either way.
> -rp
>
> I think a new name would not be so welcomed (and confusing).

Why to have two methods (to_s and inspect) doing the same thing?
They are not supposed to be aliased,
this is the case in many objects (except the ones having a unique perfect
representation).
So let's change one !

I think it's time to decide.
And I think the initial proposition is the relevant one (name convention,
backward compatibility, useful, ...).

Who (else) is disagreeing to this feature ?
... and who is agreeing ?