> As I stated in [ruby-core:27631], I don't object about having two
> string representation, one "human readable" and the other "more
> verbose". =A0Even though I am not fully against, it doesn't mean, I
> enjoy having two representation. =A0Float is float is float. =A0We should
> know about error when you treat with float, shouldn't we?

The option previously proposed is

Float#to_s : human
Float#inspect : verbose

Another option:

Float#to_s : verbose
Float#inspect : verbose
Float#to_hs : human (or to_ps or what not, for pretty string--not sure
if there is a convention for that name or not)

Any feedbacks or preferences there?  I'd probably be ok either way.
-rp