Bug #3140: gem activation has changed between 1.8 and 1.9
http://redmine.ruby-lang.org/issues/show/3140

Author: Aaron Patterson
Status: Open, Priority: Normal
Target version: 1.9.2
ruby -v: ruby 1.9.2dev (2010-04-12 trunk 27317) [x86_64-darwin10.2.0]

1.8 will raise gem activation errors where ruby 1.9 will not.

To reproduce this bug, first install these gems:

  $ gem install rubygems-bug-parent
  $ gem install rubygems-bug-child

Your gem list should look like this:

$ gem list rubygems-bug

*** LOCAL GEMS ***

rubygems-bug-child (1.1, 1.0)
rubygems-bug-parent (1.0)

Then run the following program:

    $ ruby -rubygems -e "require 'rubygems-bug-child'; require 'rubygems-bug-parent'"

Ruby 1.8 will raise an activation error because of the conflicting versions:

Here I am in version 1.1
/Library/Ruby/Site/1.8/rubygems.rb:230:in `activate': can't activate rubygems-bug-child (= 1.0.0, runtime) for ["rubygems-bug-parent-1.0"], already activated rubygems-bug-child-1.1 for [] (Gem::LoadError)
	from /Library/Ruby/Site/1.8/rubygems.rb:246:in `activate'
	from /Library/Ruby/Site/1.8/rubygems.rb:245:in `each'
	from /Library/Ruby/Site/1.8/rubygems.rb:245:in `activate'
	from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:35:in `require'
	from -e:1

Ruby 1.9 will continue along using the 1.1 version, and never detect the version conflict:

$ ruby -rubygems -e "require 'rubygems-bug-child'; require 'rubygems-bug-parent'"
Here I am in version 1.1


----------------------------------------
http://redmine.ruby-lang.org