Hi,

In message "Re: [ruby-core:29169] [Feature #2152] Split functionality of Float#inspect and Float#to_s"
    on Thu, 1 Apr 2010 02:21:55 +0900, Roger Pack <redmine / ruby-lang.org> writes:

|Matz any feedback on this patch, when you get a chance?

As I stated in [ruby-core:27631], I don't object about having two
string representation, one "human readable" and the other "more
verbose".  Even though I am not fully against, it doesn't mean, I
enjoy having two representation.  Float is float is float.  We should
know about error when you treat with float, shouldn't we?

Anyway, I feel like we still have two points:

(1) We've got consensus which method to behave which so far.  Since
    #inspect is a method for "human readable" string representation,
    I think it is more suitable to get "human readable" float
    representation.  Others want to #to_s to be "human readable" to
    ease "Float #{f}".

(2) Besides that, I am not sure whether the old behavior is the best
    way to generate "human readable" representation.

							matz.