Bug #3053: Psych should not be installed without libyaml.
http://redmine.ruby-lang.org/issues/show/3053

Author: Takashi Tamura
Status: Open, Priority: Normal
Category: lib, Target version: 1.9.2
ruby -v: ruby 1.9.2dev (2010-03-30 trunk 27101) [x86_64-darwin10.3.0]

At trunk, psych is installed even if the system does not have libyaml.
If psych continues to require libyaml, I think lib/psych should move to 
ext/psych/lib/psych, like ext/openssl/lib/openssl and ext/digest/lib/digest.

Regards.


----------------------------------------
http://redmine.ruby-lang.org