Issue #2152 has been updated by Roger Pack.

File add_float_inspect.diff added

Here's a patch which restores Float#to_s to its "human readable" form and introduces Float#inspect for the "more verbose" form.

Hopefully it will find approval (another name than inspect would be ok, too, though I prefer inspect so that in irb I can know what is going on).

I'd be happy to add tests or what not, once a decision is made (or even before, if requested).

Thanks!
-rp
----------------------------------------
http://redmine.ruby-lang.org/issues/show/2152

----------------------------------------
http://redmine.ruby-lang.org