>> I've attached a patch adding getters and setters for HEAP_MIN_SLOTS and =
GC_MALLOC_LIMIT.
>
>
> My personal opinions:
>
> - Though I think a few rough "modes" is acceptable (e.g., -server and
> =A0-clients of Java), such a specific parameter tuning is not Ruby way.

That seems reasonable.  Maybe like --conservative or --server or what not.


> - The name `malloc_limit' is very arguable because it is too specific
> =A0to implementation-detail of MRI.

agreed.

-rp