Hi,

In message "Re: [ruby-core:28735] [Bug #2982] Ruby tries to link with both openssl and readline"
    on Thu, 18 Mar 2010 17:01:38 +0900, Lucas Nussbaum <redmine / ruby-lang.org> writes:

|Ruby currently tries to link with both OpenSSL (which is under the SSL license), and Readline (GPL).

No.  The Ruby does not try to link with those libraries by default,
unless explicitly required by the user, so that it is a user's
responsibility to avoid loading those two in the same address space.

License sucks.

							matz.