Bug #2739: ruby 1.8.7 built with pthreads hangs under some circumstances
http://redmine.ruby-lang.org/issues/show/2739

Author: Joel Ebel
Status: Open, Priority: Normal
ruby -v: ruby 1.8.7 (2010-01-10 patchlevel 249) [x86_64-linux]

Ruby 1.8.7 built with pthreads is hanging for me.  I can't produce a reproducible testcase, and the problem is intermittent for me as it is, but I have traced it back to a particular patch when it began.  The hang happens on an exec, where the ruby process clones itself, and the clone hangs.  If I build ruby without pthreads it works fine.  Specifically this is happening on a run of puppet when it is loading facts.

Going back through versions of the 1.8.7 branch, it appears the problem began happening in patchlevel 183 (svn revision 24104)
If I try the 1.8 branch, problems begin happening with svn revision 23268 and become more like the current behavior with revision 23305, both of which were merged into 1.8.7 in patchlevel 183 (r 24104)

If I try newer versions of the 1.8 branch, I find that the syntax has changed, however, it's possible that the specific problem i'm experiencing is fixed in r 24400 and/or 24402 (24400 doesn't build for me, so I can't be sure which revision is responsible for the improved behavior.

I will continue trying to create a reproducible test case for this bug, but I hoped that narrowing down where the regression begins would be a helpful place to start.


----------------------------------------
http://redmine.ruby-lang.org