Hi,

In message "Re: [ruby-core:25820] [Feature #2152] Split functionality of Float#inspect and Float#to_s"
    on Mon, 28 Sep 2009 18:45:15 +0900, Roger Pack <redmine / ruby-lang.org> writes:

|I'm not totally set on using those method names--the proposal is that both be available somewhere.

I am not against provide both ways to represent float numbers, but I am
not sure to assign which behavior to which name, or to add a new
method.  We need to investigate more on names.

							matz.