Bug #2596: Openssl Segmentation Faults on Red Hat Enterprise Linux 5.3
http://redmine.ruby-lang.org/issues/show/2596

Author: Mike Hodgson
Status: Open, Priority: High
Category: ext
ruby -v: ruby 1.9.1p376 (2009-12-07) [x86_64-linux]

The following openssl tests fail either from segmentation faults or memory corruption:

openssl/test_hmac.rb
openssl/test_pkcs7.rb
openssl/test_ssl.rb
openssl/test_x509store.rb

activeresource/lib/active_resource/connection.rb also gets a segmentation fault from the require 'net/https'.

Linux kernel version is Linux: 2.6.18-164.9.1.el5xen.


----------------------------------------
http://redmine.ruby-lang.org